APR 25 - Error Updating Data
Incident Report for
MTG Arena
Resolved
The "Error Updating Data" issue has been resolved. If you continue to experience issues, please contact support:
https://mtgarena-support.wizards.com/hc/en-us/requests/new
For any other live issues, please continue to refer to our status page:
https://magicthegatheringarena.statuspage.io/
Posted
6
years ago.
Apr
25
,
2019
-
20:23
UTC
Investigating
We are investigating reports of an "Error Updating Data" error message. If you are receiving this message, please wait a few moments before trying again.
We will update you with more information once it becomes available.
Posted
6
years ago.
Apr
25
,
2019
-
17:01
UTC
This incident affected: Game.
×
Subscribe to Incident
Subscribe to updates for
APR 25 - Error Updating Data
via . You'll receive .