NOV 7 - Degraded Performance
Incident Report for MTG Arena
Resolved
This incident is now resolved. For players participating in the Omniscience draft, the event has been re-enabled and extended until Monday, November 11 at 8 a.m. PT (16:00 UTC). For all other issues, please contact support.
Posted Nov 08, 2019 - 02:20 UTC
Update
The hotfix is now available. Players will need to restart their client in order to download the latest update.
Posted Nov 08, 2019 - 00:59 UTC
Update
We will deploying an emergency hotfix at approximately 3 p.m. PT (23:00 UTC) to address the issue. This will be a required update. Players will be notified in-game when the update is available.
Posted Nov 07, 2019 - 22:21 UTC
Identified
We have identified the issue, and are temporarily disabling Omniscience draft at this time. For participating players, your current draft and/or record will be saved and we'll be extending the event to make up for the outage.

All other play queues and events are still available. We apologies for the inconvenience.
Posted Nov 07, 2019 - 20:32 UTC
Investigating
We are aware of an in issue currently affecting Magic: The Gathering Arena. Players may experience degraded performance and/or lag at this time. We will update you with more information when it becomes available.
Posted Nov 07, 2019 - 20:06 UTC
This incident affected: Game.