A fix has been implemented, and MTG Arena is back online. We are continuing to monitor the situation.
Posted Jun 10, 2025 - 21:31 UTC
Update
In order to help identify the root issue, we will be putting the game into maintenance mode. All players will be disconnected, and MTG Arena will be unavailable at this time.
Posted Jun 10, 2025 - 20:47 UTC
Investigating
We are investigating reports of players being disconnected/unable to connect to MTG Arena. We will update you when we have more information.
Posted Jun 10, 2025 - 20:18 UTC
This incident affected: Platform (Windows, macOS, Android, iOS) and Game, Logins, Matches, Social, Store.