OCT 7 - Degraded Performance
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted 14 days ago. Oct 08, 2019 - 08:20 UTC
Monitoring
We are no longer investigating reports of players being unable to login to Magic: The Gathering Arena. Players should be able to log in as normal.
Posted 14 days ago. Oct 08, 2019 - 08:01 UTC
Investigating
We are currently investigating reports of players being unable to login to Magic: The Gathering Arena. Players may receive an "Error Updating Data" message at this time.
Posted 14 days ago. Oct 08, 2019 - 06:56 UTC
This incident affected: Game and Logins.