OCT 18 - Emergency Maintenance
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 18, 2018 - 22:20 UTC
Monitoring
A fix has been implemented and the game is back online. Patch Notes are available, here: https://forums.mtgarena.com/forums/threads/40005
Posted about 2 months ago. Oct 18, 2018 - 21:33 UTC
Investigating
We will be taking the game down for emergency maintenance on October 18 beginning at 20:30 UTC. Matchmaking will be suspended beginning at 20:00 UTC.
Posted about 2 months ago. Oct 18, 2018 - 19:37 UTC
This incident affected: Game, Logins, Matches, and Store.