MAR 25 - Unscheduled Downtime
Incident Report for MTG Arena
Resolved
We are marking this issue as resolved. If you require additional assistance related to today's outage, please contact support: https://mtgarena-support.wizards.com/ Thank you for your patience.
Posted Mar 26, 2020 - 00:41 UTC
Update
Maintenance is now complete. We are continuing to monitor the situation to ensure our services remain stable.
Posted Mar 26, 2020 - 00:02 UTC
Monitoring
We are bringing MTG Arena back online, however we're continuing to monitor the situation to ensure our systems have stabilized. Maintenance is on-going.
Posted Mar 25, 2020 - 23:20 UTC
Update
We will be taking unscheduled downtime as we continue to investigate. Players will be unable to login, join matches, or make purchases at this time.
Posted Mar 25, 2020 - 22:12 UTC
Update
We will be disabling logins shortly as we continue to investigate. We will update you with more information as it becomes available, and we apologize for any inconvenience as we work to resolve this issue.
Posted Mar 25, 2020 - 21:26 UTC
Investigating
We are currently investigating reports of connection issues related to MTG Arena. Players may receive errors when attempting to login or play matches at this time.
Posted Mar 25, 2020 - 19:51 UTC
This incident affected: Game, Logins, Matches, Social, Store, and Forums.