JUN 1 - Degraded Performance
Incident Report for MTG Arena
Resolved
Our services have stabilized, so we are marking this issue as resolved. For additional assistance, please Contact Support: https://mtgarena-support.wizards.com/hc/en-us/requests/new
Posted 3 months ago. Jun 02, 2019 - 06:08 UTC
Investigating
We are currently investigating reports of degraded performance on Magic: The Gathering Arena. Players may experience disconnects and/or general lag at this time.

We will update you with more information when it becomes available.
Posted 3 months ago. Jun 02, 2019 - 02:00 UTC
This incident affected: Game.