SEPT 16 - Degraded Performance
Incident Report for MTG Arena
Resolved
Our services have remained stable, so we consider this incident resolved. If you continue to experience any issues, please contact customer service. Thank you!
Posted Sep 16, 2021 - 23:45 UTC
Monitoring
Performance has stabled, and we have re-enabled the store on @MTG_Arena. We are still monitoring the situation to ensure continued stability.

Players may need to restart their client to receive pending Store purchases. If you continue to experience issues, please contact customer service.
Posted Sep 16, 2021 - 21:53 UTC
Update
To help with our investigation, we have disabled the store at this time. Players who completed purchases will receive their items as soon as possible.
Posted Sep 16, 2021 - 20:57 UTC
Investigating
We are investigating reports of degraded performance and increased loading times on @MTG_Arena. We will update you with more information when it becomes available.
Posted Sep 16, 2021 - 20:23 UTC
This incident affected: Game, Logins, Matches, Social, and Store.