NOV 11 - Unsanctioned Basic Lands
Incident Report for MTG Arena
Resolved
A fix has been implemented. Players will need to restart their client for it to be applied.
Posted Nov 10, 2020 - 21:47 UTC
Identified
Players may experience gameplay or graphic related issues when using the Unsanctioned basic lands during matches. As a workaround, we recommend players use other basic lands at this time.

We apologize for the inconvenience.
Posted Nov 10, 2020 - 18:26 UTC
This incident affected: Matches.