Partial Outage - Mobile Devices
Incident Report for MTG Arena
Resolved
The issues should now be resolved, and the game update should be available on all supported mobile devices. Please Note: Players should expect a larger than normal download as part of this update.
Posted Sep 13, 2024 - 01:30 UTC
Investigating
We are aware of an issue impacting players on certain mobile devices that is prevent them from downloading the latest update. We are currently working on a fix, and will update you with more information once it's available.
Posted Sep 12, 2024 - 21:14 UTC
This incident affected: Platform (Windows, macOS, Android, iOS) and Game.