Player Inbox Disabled

Incident Report for MTG Arena

Resolved

This incident has been resolved.
Posted Oct 06, 2023 - 20:33 UTC

Identified

Due to issues with the @MTG_Arena player inbox, we are temporarily pausing our inbox messaging and rewards, including those for the 5th Anniversary. Once the issues are resolved, we will continue our messaging and rewards as planned.
Posted Sep 25, 2023 - 20:12 UTC
This incident affected: Social.