Arena Direct - Duskmourn: House of Horror Store Links

Incident Report for MTG Arena

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 00:00 UTC

Monitoring

Eligible players will be receiving an email shortly with the corrected links for their Arena Direct Prize Redemption. We will continue to monitor the situation to ensure the issue has been fully resolved.
Posted Feb 13, 2025 - 23:48 UTC

Investigating

We're aware of an issue with the Duskmourn: House of Horror store links recently sent to Arena Direct participants. We are working to resolve this issue, and participants should expect additional information sent to their registered email address soon.
Posted Feb 13, 2025 - 22:28 UTC
This incident affected: Store.