Purchasing Issues

Incident Report for MTG Arena

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 16:20 UTC

Investigating

We're currently investigating issues with purchases in MTG Arena and have temporarily disabled purchasing across platform. Players can spend gems as normal.
Posted Nov 05, 2025 - 22:43 UTC
This incident affected: Store.