We are aware of an issues affecting Player Draft, and will be temporarily disabling the events at this time. Scheduled maintenance is still on-going.
Posted Dec 03, 2024 - 17:32 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 03, 2024 - 16:30 UTC
Scheduled
@MTG_Arena maintenance will occur to deploy the 2024.43.30 game update, containing important backend updates. Players may experience login issues while maintenance is in progress. There are no patch notes associated with this release.