JUN 20 - Degraded Performance
Incident Report for MTG Arena
Resolved
Our services have stabilized, so we are marking this issue as resolved. For additional assistance, please Contact Support: https://mtgarena-support.wizards.com/hc/en-us/requests/new

Thank you for your patience, and we apologize for any inconvenience.
Posted 4 months ago. Jun 21, 2019 - 15:44 UTC
Identified
We are investigating reports of network issues while playing Magic: The Gathering Arena. Players may experience disconnects and/or increased latency at this time.

We will update you with more information when it becomes available.
Posted 4 months ago. Jun 20, 2019 - 23:40 UTC
This incident affected: Game and Logins.