DEC 15 - Theros Beyond Death Pre-Orders
Incident Report for MTG Arena
Resolved
This issue is now resolved. Players who pre-ordered Theros Beyond Death will receive the rest of their in-game items as part of tomorrow's game update.

For more information on scheduled maintenance, click here: https://magicthegatheringarena.statuspage.io/incidents/j97zj05cdq16
Posted Jan 16, 2020 - 04:08 UTC
Investigating
We are investigating reports of an issue affecting Theros Beyond Death pre-orders. We will update you with more information once it becomes available.

Theros Beyond Death content will not be available until after tomorrow's game update.
Posted Jan 16, 2020 - 00:31 UTC
This incident affected: Store.